Install Issues Try Snowplow

Issues with installing Try Snowplow. Any suggestions on how to resolve?

Looks successful in AWS but in Snowplow it continues to spin. No URL is produced or sent.


Hi @Adam, thanks for flagging! Our engineers will take a look at this now, and we’ll let you know as soon as we find the issue

Hi @Adam, first of all, apologies for the issues you are incurring in setting up your Snowplow trial!

After checking your account it looks like your pipeline details were not registered correctly. This leads us to believe there has been some issue with setting up the agent as part of your Try Snowplow stack.

To debug the issue, could you please check the events in CloudFormation for any errors and share those with us? We do not have any access to your cloud account and therefore cannot see this kind of information directly.

Alternatively, you could try deleting the stack and going through the CloudFormation setup process again?

Let me know if these screenshots help.

Hey Adam, sorry for the bumpy road and thanks a bunch for helping the Snowplow get better.

The screenshots suggest that all the pieces for the trial got created yet there was a runtime problem that wasn’t automatically recovered.

Deleting the stack and redeploying should solve it for you. Each AWS account setup is slightly different, so if you feel adventurous, you could try to debug the reason this happened by looking at ECS (where your Snowplow trial runs) logs.

The procedure should be something along the lines (using the new AWS UI):

  • navigate to
  • find & open your Snowplow cluster
  • switch over to Tasks tab and see the list of (failed) tasks
  • open up the most recent failed task
  • switch over to Logs tab
  • browse through the list to see if there’s anything looking scary

Hi, I deleted the stack and tried to redeploy but still the same issue. As for the logs there are many failed tasks of different sorts.