Timeout Apply Iglu Server

When I run terraform apply on iglu_server, timeout happens at this point:

This can often happen (Terraform timeouts) if your health check is consistently failing. Can you check your logs for the Iglu server instance in Cloud Logging and look for any errors that may be preventing it from starting?

Hi @cristhians13 can you please have a look at the logs from the instance that attempts to boot? Generally speaking this is an issue coming from the boot-script as the instance never becomes healthy.

The only error log is this one regarding the public key, but I created it following the documentation ssh-keygen -t rsa -b 4096

Hey @cristhians13 could you share your tfvars file with us please so we can take a look at this?

Hy @josh, thanks for the feedback.

Here is the link to the repo with the information.

Thanks @cristhians13 nothing pops out at me there - have you tried deploying without the SSH key-pair to see if that removes the deployment issue?

Hi @josh , I was using Windows and did a new test using Linux. The terraform asked me to enable these features in GCP:

  • Compute Engine API
  • Cloud Resource Manager API
  • Identity and Access Management (IAM) API
  • Cloud Pub/Sub API

And now it worked. Thanks for the help.

Hey @cristhians13 if you have the time it would be great to get if you could open a PR (or let me know where in the flow this got lost) to the documentation you followed which would have avoided this pain!

Was it around here that activating the APIs should have been called out? Quick Start Installation Guide on GCP | Snowplow Documentation

Hi @josh
Of course, I opened an issue to enter the information in README.md
Requirements Iglu Server - GCP #39

2 Likes

Thanks @cristhians13 I have updated our quick-start guide in the Docs site to include these details now.

@josh I was having the same problem of the instance group not starting. Another API is needed as well:
Cloud SQL Admin API

It would be helpful to add advice to change the prefix as well. If you leave this unchanged the pipeline deploy fails as prefix is the only thing used to make the bucket name unique.

Thanks @SteveB have added a PR to update the docs with that API needing to be enabled. Apologies for any debugging confusion caused!

This is being discussed here also @SteveB and curious for feedback on which way we should go here. It was always assumed users would change the prefix for entropy but obviously there is more we could do here to prevent collisions and smooth out the user startup experience.