Schema Guru WEB-UI opens a blank page

I followed the steps mentioned here:

I was able to start the server but somehow I can only see a blank screen while trying to access the page.

I am attaching the page source. 28 PM

The server shows up this when I run the file.

Your akka binds port 8080 and you open 8000 in browser…

Hey @ramandamodar,

Could you please also show a Chrome Console output?

Hi @anton

38 AM

The console shows: GET http://localhost:8080/dist/bundle.js net::ERR_CONTENT_DECODING_FAILED

@grzegorzewald My bad. I tried both the ports. But it still isn’t working.

Hey @ramandamodar,

Is it possible you have plugins in your browser that do additional content/headers checks? Because I just successfully downloaded a fatjar and launched it as described in README. But indeed there’s a subtle bug (indicated by ERR_CONTENT_DECODING_FAILED) that asset is served with Content-Encoding gzip, but in fact not gzipped - in both latest Firefox and Chrome it didn’t cause any problems though - that’s why I suspect 3rd-party extensions on your computer.

Thanks @anton

I tried disabling all the extensions and tried again but still faced the same problem.

I have now hosted Schema Guru on one of my ec2 instances. It works fine (with all the extensions enabled).

1 Like