Custom Schema Error

I have create schema. When i try to check with iglucli command
i.e ./iglucli lint 1.0.0
It passes validation in local host

“$schema”: “”,
“description”: “Schema for Create Case event”,
“self”: {
“vendor”: “”,
“name”: “create_case”,
“format”: “jsonschema”,
“version”: “1-0-0”
“type”: “object”,
“properties”: {
“caseDescription”: {
“description”: “descript this column”,
“type”: “string”,
“maxLength”: 500
“required”: [“caseDescription”],
“additionalProperties”: false

But when i run the same command, it gives error
Given $schema is not

Help me! @PaulBoocock

@lalspicesresearch the error message tells you what’s wrong. the value of $schema must be

1 Like

@Colm thank you for your reply. Now can you help with me, when i trigger page view event, a file in snowplow-bad-enriched-event s3 bucket is uploaded by data firehose.

{"schema":"iglu:com.snowplowanalytics.snowplow.badrows/collector_payload_format_violation/jsonschema/1-0-0","data":{"processor":{"artifact":"snowplow-stream-enrich","version":"1.0.0"},"failure":{"timestamp":"2020-09-15T14:36:12.010Z","loader":"thrift","message":{"error":"error deserializing raw event: Cannot read. Remote side has closed. Tried to read 2 bytes, but only got 1 bytes. (This is often indicative of an internal error on the server side. Please check your server logs.)"}},"payload":"####="}}

Where should i check? Do i need to setup anything? I have setup collector (scala stream collector) , tracker, enrich (stream enrich). Help me