Requests to "https://{{ collector_url }}/com.snowplowanalytics.snowplow/tp2" returned 408 for clojure collector and 403 for cloudfront collector

This is a collector and javascript tracker issue that I am facing. The event tracking is stuck at sending the request to https://{{ collector_url }}/com.snowplowanalytics.snowplow/tp2 with OPTIONS method. I suppose the this should redirect to the pixel i url but it doesn’t seem to redirect.

I tried out both the cloudfront collector and also the clojure collector. The urls for the pixels i are here:

Both cloudfront collector and clojure collector were able to initiate the snowplow tracker, and create cookies with event payload we specified. However, the process I am getting “403: FORBIDDEN” for the cloudfront collector, while clojure collector simply timed out with “408: REQUEST_TIMEOUT”

I saw this post here and tried the suggestion to disabled port 80 on the clojure collector. When I did that however, the health indicator of beanstalk environment turned “severe”.

Cloudfront request and response

Clojure Request

Clojure Response Timed out


I figured out the error from the clojure collector was coming from incorrect Classic Load Balancer settings.

Attached is the correct settings, in case others run into the same issue with setting up Clojure collector.

Note that the Instance Port for BOTH listener port 80 and 443 should be 80.

Now I hope I could figure out the solve the 403 error with cloudfront collector.

Did you ever figure out what was wrong with the cloudfront collector? I’m having the same 403 error.

Hi @Nick_Latocha the CloudFront collector does not support POST requests which it would be returning 403 response codes - it can only accept GET requests.

1 Like