Problems with Vagrant and our GitHub repositories?

Almost all of the Snowplow GitHub repositories include Quick Start guides using Vagrant. Sometimes there is a problem with the Ansible-based deployment process which takes place (only once) on vagrant up.

Typically this will tell you that you have a problem:

guest> which sbt
sbt not found

If this happens to you, then:

guest> exit
 host> vagrant halt
 host> vagrant destroy
 host> rm -rf vagrant/oss-playbooks vagrant/ansible vagrant/.peru
 host> vagrant up

Then go for a long walk, come back and:

 host> vagrant ssh
guest> which sbt
1 Like

Hi Alex,

I had already tried that and it still fails.

I think its related to some kind of issue with peru such as the one described here:

Thanks for the update pj - have you tried removing that setting from your .gitattributes and re-running?

Still doesn’t work on my machine,

Righ tnow im trying to up the Snowplow/avalanche

im using :
-> Windows 10 as Host OS
-> Virtualbox 5.0.16
-> Vagrant 1.8.1
-> Vagrant box :
– ubu/trusty64-ansible-1.9 (virtualbox, 1.1)
Error Message : [ Still The Same Error Message That You Mention Above]
– leucos/trusty64-ansible-1.9 (virtualbox, 1.1)

         ` Error Message : 
	   ==> default: ERROR: The file /vagrant/vagrant/ansible.hosts is marked as executable, but failed to execute correctly. If this is not supposed to be an executable script, correct this with `chmod -x /vagrant/vagrant/ansible.hosts`.`

Can you explain the your vagrant version, vagrant box, and virtualbox version?