GTM SS - No client claimed the request

Hi, I’ve tried to experiment with GTM SS to see if its possible to pass conversion events to google/fb; I managed to run the server container (setup manually, using this as template - gtm-server-container-cluster 0.1.2 · joaquinito2051/trieb-work), but when I run simple POST request sp client for some reason doesn’t claim request, even when I tried example from here: Building an Enriched event relay for GTM SS - Snowplow Docs

strangely enough, the GET requests do work for impression collection like /i but not for POSTS to /com.snowplowanalytics.snowplow/tp2

Here is the client config which has default values:

The preview request:

So not sure if I missed something when configuring, or the issue could be with GTM SS container

Hi @evaldas
Not sure if you saw the November Office Hours, but there was a demo of using it - there may be something there that might help?

1 Like

Hi @evaldas!

From the second screenshot it seems the POST request goes to, which is not the default path the Snowplow GTM SS Client claims requests to. The default path is /com.snowplowanalytics.snowplow/tp2, exactly as you also mention.

You can still set another custom POST path in the client configuration if you wanted to.

Hope this helps too!


hey @Ada, thanks, that was the issue! I assumed the default path is but in the template for some reason its com.snowplowanalytics.snowplow/tp2 good catch, now it does work as expected.

I do have 1 side issue with container responding 404 for whatever reason, but that’s likely to be the issue how I deployed it.

1 Like

Thanks for the update - really useful for others to know what worked, etc.

1 Like