Forcing Secure Protocol on Snowplow GTM template

Hi all, theres a problem I’m having that I can’t quite seem to solve.

I’ve set up the Snowplow Javascript Tracker via GTM using Simo Ahava’s templates.. I’d like to preview the new tags I created on my local copy of the codebase. So when entering GTM preview mode I input my localhost (http://localhost). However, our collector uses https secure protocol. Using the Snowplow chrome extension I can see the response to collector requests is 0 (as opposed to 200) and the request uses http (as opposed to https).

I’d like the Snowplow tracker to force https for the collector.

Things I’ve tried:

  1. Changing the Snowplow GTM template itself to force https. Running the changes on the template I can see that the forceSecureTracker is set to true. However when I use that template and preview tags which use that template the request is not enforcing secure protocol.

  2. Enforcing https in the Variable we created which uses the template.

  3. Enforcing https in the individual tags which reference the Variable that uses the template.

All of the above options I’ve tried don’t seem to work to enforce https as I still see http in the request header.

Any help or ideas to force https for the collector would be greatly appreciated!!

Are you using v2 of the JavaScript Tracker? Which version if so? The GTM template currently only supports v2, we intend to update it to v3 later this year (I ask this as v3 no longer has the forceSecureTracker flag).

If you’re using v2, this could be a template issue. Let me know.

As a workaround, you can try and override it in the Snowplow Template rather than in the Settings template? See if this helps?

Yes, we’re using v2 because we noticed in the docs that v3 isn’t supported in the GTM template

I got the same issue with @Lauren_Ribeiro. Just tried this solution, but it does not work.