Error Getting Credentials using GOOGLE_APPLICATION_CREDENTIALS


New to Snowplow OS here and currently on the process of trying to set up a Secure Pipeline in GCloud.

I am stuck at the “Terraform Plan” Step for the Iglu_server, I am getting this error:

I have generated the GCloud JSON key 3 times, tried different paths (triple checked the paths in the returned error, the Key is right where is says it is on the error, even copied the path from the error and pasted on my explorer and it immediately open the file).

Also tried using the “gcloud auth application-default log”, even went as far as to replace the content of the “gcloud\application_default_credentials.json” with the one of the Generated JSON key, nothing works.

Any advice or tips or help would be greatly appreciated.

Hi there,

I’ve seen that error before and it usually means I’ve made some clerical error in pointing to my credentials.

What happens when you run this gcloud command? If it errors, that confirms it’s something about pointing to the credential file.

Hi Colm,

Thanks for the reply.

if I run that command on my service account and project I Get this:

Actually Colm,

Thanks for the help I realize the difference between the set Command and the second command you sent… I was Including " " in the path of my first command, and this was causing the error, the path should have been added without double quotes or any other quotes for that matter.

Thanks for the help, you made me realize that mistake.

Now I just need to go trough the list of all of the permission errors I am getting after running “Terraform Apply”:

Nice, glad it helped!

This might be helpful in navigating the permissions part of the process: Setup Snowplow Open Source on GCP - Snowplow Docs

If there are things you need to enable that aren’t covered in the docs please let us know. :slight_smile:

Thanks Colm that was super useful, made me realize I had the Json Key for an account that was not the service account associated with the project/network where I want to deploy the Igloo server and pipeline.

Terraform seem to be running correctly now, it has been running for 9 minutes and is still creating the DB instance, but Until It throws and error I am just going to let it be.


1 Like

It can take a good while to create the DB instances :slight_smile: Go get a coffee :coffee:!

1 Like

Thanks for all the help so far! =)

I am almost there, got a couple of permissions errors in the “compute_region_instance_group_manager” creation step do to some missing permissions:

After that I tried doing “Terraform Plan” a couple of times but it kept Timing out on the same step:

And Also running “Terraform Apply” times out on the same point:

I tried both commands multiple times but same result (after a long waiting time). Any ideas of what to do to Rollback or Re-do This step would be greatly appreciated.

Thanks in advance for all the help!

Also a small suggestion from a clueless guy how is working with Gcloud for the first time, if you could add all of this “Permissions” in the “Prerequisites” section of the Quick start guide that would be awesome, bonus points if you can add little pictures of where to go to turn on what =D