Snowplow-micro help

I’m trying to run snowplow-micro so as to be able to create pipeline from a small blog app. I’m somewhat unfamiliar with Docker and haven’t been able to make sense of the instructions for running snowplow-micro. When I run;

docker run --mount type=bind,source=$(pwd)/example,destination=/config -p 9090:9090 snowplow/snowplow-micro:latest --collector-config /config/micro.conf --iglu /config/iglu.json

I get the error;
Error: Configuration file ./example/micro.conf does not exist
Error: Configuration file ./example/iglu.json does not exist
Try --help for more information.
Exception in thread “main” java.lang.RuntimeException: Problem while parsing arguments
at com.snowplowanalytics.snowplow.micro.ConfigHelper$.parseConfig(ConfigHelper.scala:73)
at com.snowplowanalytics.snowplow.micro.Main$.main(Main.scala:34)
at com.snowplowanalytics.snowplow.micro.Main.main(Main.scala)

I’ve downloaded copies of the 2 config files that are missing, but am unsure where to place them so they they will run. Any help would be much appreciated.

Hi @mcor, welcome to the Snowplow community!

You’re running the right command. The $(pwd) in the source= bit resolves to your current working directory. So if you run this command from a directory with a subdirectory in it called example with the micro.conf and iglu.json in it, the command should work ok.

~/snowplow-micro <-- run your cmd here

Then visit http://localhost:9090/micro/all to see if it works.

Let me know if it doesn’t.

Hi Steve thanks for your help, it helped clarify what the command was doing. It seems the problem actually had something to do with how I originally downloaded the files. I had originally downloaded from GitHub using the download button. I tried deleting everything and cloning the repository from the command line. That seemed to do the trick and I was able to run the command and get the app running.

Thanks again!