IP_Lookups not working with S3

I have created the ip_enrichment config as described for S3 per instructions: IP Lookup enrichment | Snowplow Documentation

The resulting error indicates S3 is not an appropriate file client. The bucket name and path have been replaced, but the actual error displays the correct path as defined in the config.
java.lang.IllegalStateException: No client initialized to download s3://blah-bucket/blah-path/GeoLite2-City.mmdb

Are there other settings that must be defined? The Role assigned to the enrichment process has read and list rights on the bucket and for all contents within the bucket.

Hi @JMR ,

Welcome to Snowplow community!

Are you running snowplow/snowplow-enrich-kinesis ?

Hey @BenB ,

I am running the Kafka version, snowplow-enrich-kafka
Version 3.7.3

Kafka app doesn’t include the libraries to read from S3.

Assets for the enrichments should be linked via http:// or https:// in the config.

1 Like

Thank you for the information about the Kafka version.