Snowplow_web package installation (v.1.0.0)

Hey there,
plan to install snowplow_web package (version 1.0.0) in :dbt: dbt and while installing the package (run dbt deps) - got an error:

Version error for package dbt-labs/dbt_utils: Could not find a satisfactory version from options: ['=0.9.6', '>=0.1.25', '>=0.9.0', '<2.0.0', '>=1.0.0', '<2.0.0']
make: *** [run-dbt] Error 2

Dig a bit deeper and see in the file: there is no support for package version 1.0.0 - 0.15.2 is maximum.

Question: are you responsible for managing this file? If yes, what is the ETA to introduce v 1.0.0?


UPDATE: works now with v.1.0.0 as used dbt_utils v1.0.0 (no problem with the installation).

Hi @Radovan_Bacovic, glad you solved it. For anyone else who finds this thread, you had some other package that wanted specifically version 0.9.6 of dbt_utils, but our packages require at least version 1.0.0 of it.

Hey @Ryan - thanks for the fast response.

Yep, didn’t see explicitly we need to have dbt_utils 1.0.0 (at least), then checked the .json file and yes - the combination with snowplow_web 1.0.0 and dbt_utils 1.0.0 works fine.