Snowplow blocked by Brave Browser?

I setup snowplow on AWS using the Quick Start guide.

I created a subdomain and pointed it to the collector via a CNAME.

When I try to track a PageView, it’s getting blocked (Brave Browser). All other scripts (including other tracking scripts) load fine.

Shouldn’t it be loaded since it’s all first party and on my own subdomain?

Maybe its the “com.snowplowanalytics.snowplow” in the url part? Can this be changed? Anyone else experienced something like this before?

UPDATE: Just found something in the firstparty blocklist of Brave


I guess I have to change the “com.snowplowanalytics.snowplow” part then…

Hi Moritz,

it is possible to bypass any analytics blocker I know with Snowplow. What you need to do:

  • User the browser tracker to avoid side loading of sp.js (otherwise rename sp.js and load it from first party endpoint)
  • Use a first party endpoint (as you mentioned), but via A record and not via CNAME since a couple of browser are detection so called cname cloaking
  • Change the request path to a custom path in the postPath: ‘/custom/path’ and change the cookieName: 'your_name, via tracker-setup/initialization-options
  • To avoid any impact of Safari ITP use the Snowplow ID service or place the collector endpoint behind your CDN
  • It is also possible to change the name of the networkUserId cookie sp, but I haven’t found a issue with a blocker yet

Kind regards.


Based on your edit,

I guess I have to change the “com.snowplowanalytics.snowplow” part then…

That seems correct. Kind of funny in a way as this very site was up till very recently, guess brave didn’t like the old domain, glad we rebranded for them :joy:.

@davidher_mann pointed you in the right direction re: trackers, but I’ll just point out that you also need to configure the collector’s custom post paths.

1 Like

Thank you @davidher_mann @Colm .

Changing the custom path did the trick! :slight_smile:

1 Like