GCP Quick Start not receiving test event


I’m following the GCP Quick Start Guide. I have everything setup (iglu server, pipeline) but when querying test event (sent with CURL command) I’m not seeing anything…

  • Running CURL test event command from my local terminal returns me OK message
  • I tried to pull some messages from pub/sub subscriptions but I’m not getting anything
  • I’m looking at gcp log project, I’m seeing a bunch of stuff but nothing that’s look like an error (I can see log from the loader-enriched-server and the loader-bad-server)

Since I’m not seeing any obvious error messages I’m not sure where I should go from there? What can I do to debug this? How can I know which part of the pipeline is not working?


I’m seeing this in the log from the loader-enriched-server which looks like an error:

fs2.CompositeFailure: Multiple exceptions were thrown (2), first java.net.MalformedURLException: no protocol:



What is your Iglu resolver configuration? It looks like the Iglu URI is potentially missing a protocol. might need to be a different URI in your config.

Where can I find this URI? The only information I have after running the terraform iglu_server is the IP. I can check the load balancer but not really finding anything different from the IP. I’ve tried to add the port (xx.xx.xxx.xxx:xx) but it also give me an error.

It should come as a Terraform output of the Iglu Server setup (specifically iglu_server_dns_name).


I might be missing something but as far as I can see I only get this IP. Also this is what’s mentioned in the outputs.tf file

output "iglu_server_ip_address" {
  description = "The IP address for the Iglu Server"
  value       = module.iglu_lb.ip_address
1 Like

And then for the variables for the next step what have you got defined for iglu_server_dns_name ? (i.e., in terraform.tfvars)


ok It’s working. I think it was just a typo on my terraform vars.