Error deserializing raw event: Unrecognized type 67

I’m trying to use the enrichment process to do schema validation from an event pushed from the PHP SDK. Currently I’m getting the following error from the enrichment process:

error deserializing raw event: Unrecognized type 67

The data I’m sending through the collector:


The schema looks like this:

“$schema”: “”,
“description”: “Platform login event data schema”,
“self”: {
“vendor”: “com.vendor”,
“name”: “platform_login”,
“format”: “jsonschema”,
“version”: “1-0-0”
“type”: “object”,
“properties”: {
“contact_id”: {
“type”: “number”
“customer_id”: {
“type”: “number”
“required”: [“contact_id”, “customer_id”],
“additionalProperties”: false

Does anyone have any ideas what this error might be?

Is this from the collector or the enricher? Do you have the full JSON failed event for this? (should have a schema of something like: iglu:com.snowplowanalytics.snowplow.badrows/collector_payload_format_violation/jsonschema/1-0-0 )

As is I can’t see anything wrong with that schema and the instance you are sending with it but it’d be helpful to see the redacted full event you are sending if possible.

It is from the enricher. This is the full JSON:

“error”:“error deserializing raw event: Unrecognized type 67”

Thanks in advance :slight_smile:

Are you able to selectively redact this as it looks like the error is related to the payload itself?

I think v3 is still a release candidate at this stage so it might be better off using the latest 2.0.3 for now.

Thanks, I pulled and tried with 2.0.3, but now I’m getting the following error:
error deserializing raw event: Cannot read. Remote side has closed. Tried to read 2 bytes, but only got 0 bytes. (This is often indicative of an internal error on the server side. Please check your server logs.)

I checked the server logs but there’s no snowplow related output at all.

Do you have any idea what this could be?

Are you seeing this repeatedly or just a once off? Typically when I’ve seen this in the past it’s just been due to restarting the enricher / collector and should disappear afterwards.

It’s a constant error on our side, and restarting the enricher doesn’t help… :upside_down_face: