Changing core instance type to m4


We tried changing the EMR core instance type from m1.large to m4.large , without any additional changes to the configuration file.
The EMR job got stuck in the enrichment phase for 22 hours (when usually it finishes within 10 minutes) so we killed the job.

We are working on Snowplow revision 104.

Is it a problem working with this instance type or is it requires additional configuration?


We’re using the M4 already for years with snowplow and it happend 1-2 times that the machines got stuck, but it’s shouldn’t happen that often. Can you just try again maybe? It shouldn’t be a problem with the M4 instance type

1 Like

The older m1 generation of instances all had instance storage built in and it wasn’t possible to attach EBS volumes. The later generations (m4-m5) are EBS only with no instance storage, this means that for your core instances you’ll need to update the configuration to attach an EBS volume to each core node.

Thank you both for you assistance.
I tried both solution, but the issue still stands.
I’m leaving it as is for the moment.